Free Support Forum

Conholdate.Total License Error

I have loaded the aspose.total and the groupdocs.total from neget. I have tried loading the license as specified on the documents and always receive an invalid license error. Some help as to what to do would be much appreciated. The license is in a network share as the development machine is virtual. I have loaded the license with license.setlicense as described. I have been using aspose.pdf purchased several years ago with the license in the same location with no issues.

1 Like

@mikefield-1

This issue is reproduced at our end. We’re now investigating this behavior, you’ll be notified about the outcomes ASAP.

@mikefield-1

I’m escalating this issue so it can be resolved the earliest possible and you’re able to use the license properly.

@mikefield-1

Can you please further provide following details:

  • Exception details that you are facing and when the exception is exactly invoked
  • Do you get this issue when using multiple APIs (Aspose and GroupDocs together) in a single project?
  • Do you face same issue when either Aspose or GroupDocs APIs are used (not together)?

I have tried with aspose.pdf and it worked followed by aspose.barcode which failed. Both in the same debug session. pdf was first barcode was second. The error on barcode, was System.InvalidOperatoinException:‘The license signature is invalid’.

I tried the aspose.barcode by it self and received the same error.

i tried the groupdocs.annotation by it self and it worked. I tried groupdocs.annotation and groupdocs.parser together and it worked.

It appears to be very inconsistant, some that failed yesturday are better today. I have noticed that the nuget packages are more tempermental than the direct download dll only items from the website.

The aspose barcode seems to be a issue all the way around.

@mikefield-1

Thanks for the details. We’ll further look into this scenario.

We have the same error as the TO. Groupdocs.Viewer and Aspose.Email registers successfully, Aspose.BarCode fails with the following error message:

“Failed to set license. Details: Invalid license signature. Please make sure the license file was not modified.”

1 Like

@ramomJr

This issue was reproduced at our end. We are already investigating it and it’ll be resolved ASAP. As there’s any update, you’ll be notified.