We're sorry Conholdate doesn't work properply without JavaScript enabled.

Free Support Forum

License not working on GroupDocs Redaction?

Hi,
After installing the license the following code sequence:
public class Program
{
public static void Main(string[] args)
{
new License().SetLicense(@“C:\Conholdate.Total.NET.lic”);
var r1 = new Redactor(@“C:\English.PDF”);
var r2 = new Redactor(@“C:\English (1).PDF”);
}
}
returns

GroupDocs.Redaction.Exceptions.TrialLimitationsException: 'Trial mode allows only 1 document to open'

at GroupDocs.Redaction.Integration.DocumentFormatInstance.Load(Stream input)
at .Load(Stream )
at GroupDocs.Redaction.Redactor.(Stream , String , DocumentFormatConfiguration )
at GroupDocs.Redaction.Redactor…ctor(String filePath)
at Components.GroupDocs.Program.Main(String[] args)

The license file has expiry date 2023/05/27.

We’re using version 21.9.0(latest). We have tried running this targeting .NET6, .NET5, .NET Core 3.1, .NET Framework 4.8 and they all produce the same result. Please advise!

Regards!

1 Like

@omarinoiu

Could you please share the license in a private message? We’ll then look into this scenario at our end.

@omarinoiu

We cannot reproduce this issue at our end using the License file you shared. Please have a look at this screenshot.png (20.6 KB). However, we face similar issue.png (26.2 KB) if License is not applied.
Could you please share your development environment details (OS name and version)? It’d be great if you share a short video explaining steps to reproduce the issue.

Hi! Sent you the sysinfo and a project that reproduces the issue.

Thanks,
Ovidiu.

1 Like

@omarinoiu

We noticed that the exception is generated when GorupDocs.Redaction is used with other Aspose APIs (e.g. Aspose.Imaging or Aspose.HTML). However, if we remove these Aspose APIs, we don’t get any exception.
We are further investigating this issue. Your investigation ticket ID is REDACTIONNET-407. You’ll be notified in case of any progress update.

If we remove Aspose.HTML we’ll get the following exception:
System.IO.FileLoadException: ‘Could not load file or assembly ‘Aspose.HTML, Version=20.11.0.0,Culture=neutral, PublicKeyToken=716fcc553a201e56’. General Exception (0x80131500)’
at GroupDocs.Redaction.Configuration.RedactorConfiguration.GetInstance()
at GroupDocs.Redaction.Redactor.(Stream , String )
at GroupDocs.Redaction.Redactor…ctor(String filePath)
at Program.$(String[] args) in C:\ConholdateLicense\Program.cs:line 6

I’ve sent you an email with the updated project.
Can you please share that project that worked for you?

Thanks!

1 Like

@omarinoiu

We will investigate this scenario as well. You’ll be notified in case of any update.

@omarinoiu

It’s been observed that this issue occurs with the latest versions of Aspose APIs (as you are using multiple Aspose APIs in your application). However, we’ll fix it in GroupDocs.Redaction for .NET 22.7 (upcoming release). As there’s any ETA of release, we’ll notify you.
Meanwhile, you can use Aspose APIs, released before June 2022.

We’ve been testing with the suggested approach unfortunately we haven’t managed to make it work

We have tried with an older version

*PackageReference Include=“Aspose.PDF” Version=“21.8.0”*
*PackageReference Include=“GroupDocs.Redaction” Version=“21.9.0”*
*PackageReference Include=“Aspose.HTML” Version=“20.11.0”*
*PackageReference Include=“Aspose.Words” Version=“21.1.0”*

Unfortunately the same trial error still persists.

Please check the project I’ve sent to you (98.2 KB)

Also if we remove the r2 redactor, we’re receiving this exception:

*Exception of type ‘System.Exception’ was thrown.*

*at #=quPTiLpxYNhZlRP04nT1BFPCvQQqpZPUJ0gPuU9g8Z38=.#=ztqWk6ArGugCCNlwzvfcA1EvZ1WPr(Byte[] #=zLnZpAT11xjuWwse3h$zi142EPOkd)*

*at #=quPTiLpxYNhZlRP04nT1BFPCvQQqpZPUJ0gPuU9g8Z38=.#=zCWkygXgNXqUqv3c2dkizcSSsNevB.#=zA1WFNZclAxuUuSxwH2UUb5seYcUX(#=zfiztNvaMWhMnjiJ98LUsNoZMLXE9 #=zoCmrtWL3VXp9qaY9JQ5YIhVlGuHS)*

*at #=quPTiLpxYNhZlRP04nT1BFPCvQQqpZPUJ0gPuU9g8Z38=.#=z05vo9g7pkfPDKZIDOEmYN98=(String #=zZ0UKuOLyfD1g_q1Fz3HOb9WdNrSw)*

*at #=qxm70VrWsyNwo7t$cLiyAar0dqQRGJJ6Ca4y_lTXvM8g=.#=zXyYurZAikDI5jER2Oc8ATzWp2mZq.#=zQnQOAnlfr7B_D4a3RIooFvH1ZQ$S(String #=zFQGmBhA$Y9gYePYJ6qUWQbg=)*

*at #=qxm70VrWsyNwo7t$cLiyAar0dqQRGJJ6Ca4y_lTXvM8g=.#=zXyYurZAikDI5jER2Oc8ATzWp2mZq.#=z94v89WfO4RQusy56EQtcC9wMqOSS()*

*at #=qxm70VrWsyNwo7t$cLiyAar0dqQRGJJ6Ca4y_lTXvM8g=.#=zWOOaEMudsTN_XJ5OiN8JYCn4EZFY(String #=ztC8sCXU=)*

*at #=qxm70VrWsyNwo7t$cLiyAar0dqQRGJJ6Ca4y_lTXvM8g=.#=zQDzEa5sosAXt3L4oicqQP8sabwXb(Object #=zn5QAa6bUHCGPJ6ufwP4eJfvktBRY, ResolveEventArgs #=z7URzaBI6ZfIK7rd80H1yX$RidzAm)*

*at System.Runtime.Loader.AssemblyLoadContext.InvokeResolveEvent(ResolveEventHandler eventHandler, RuntimeAssembly assembly, String name)*

*at System.Runtime.Loader.AssemblyLoadContext.OnResourceResolve(RuntimeAssembly assembly, String resourceName)*

*at System.Reflection.RuntimeAssembly.GetResource(QCallAssembly assembly, String resourceName, UInt32& length)*

*at System.Reflection.RuntimeAssembly.GetManifestResourceStream(String name)*

*at #=z0aZUJ8EioWTt950JKuhs9HvQsbgV.#=zZ2mlAmHD2y_I(String #=zwgpnuTg=, String #=zq6$NPlo=, Assembly #=z8tZ9luo=)*

*at #=zivHMpuGKu7N7gWkY4coAwkDWDc_$NJ8I9h9kWGI=.#=z6RiyeP72TGxX(String #=z6vMFEG8=)*

*at #=zivHMpuGKu7N7gWkY4coAwkDWDc_$NJ8I9h9kWGI=.#=z9TVicd8GAtkt()*

*at #=zivHMpuGKu7N7gWkY4coAwkDWDc_$NJ8I9h9kWGI=.#=z5bpclPZp7Hd1()*

*at #=zxh0AfxNxpXdo9GgsCtm7Nshr7KWg.#=zIiuSgNs=(#=zW5Xa4oeC9xkdrg53c7m_9OTQ4mdiUcPuPxWyFowMOefN& #=zhYUYDfU=)*

*at Aspose.Pdf.Devices.ImageDevice.#=zIiuSgNs=(Page #=z_YScxFY=)*

*at Aspose.Pdf.Devices.PngDevice.Process(Page page, Stream output)*

*at Aspose.Pdf.Facades.PdfConverter.#=zQybqYVs8ARXhbzbQxg==(Page #=z_YScxFY=)*

*at .Rasterize(Stream , RasterizationOptions )*

*at GroupDocs.Redaction.Redactor.Save(Stream document, RasterizationOptions rasterizationOptions)*

*at Program.$(String[] args) in C:\ConholdateLicense\Program.cs:line 12*

@omarinoiu

We cannot reproduce this issue using GroupDocs.Redaction for .NET 22.7. Please integrate latest version of the API in your project and let us know if issue persists.

Hi Atir,

We have updated to the latest version (22.7). It no longer throws an exception requiring other aspose libraries, so we only used the Conholdate redact package. The result contains no redactions and is just a rasterized version of the input file. According to the results returned by the Apply method, the status is failed and the stack traces are as follows:

Failed
System.NullReferenceException: Object reference not set to an instance of an object.
   at #=zk_baTkeGsSyYK2fUlwbWQarGwinOOEZFWx_RVxPj7D6O9uRtCo$N$Ns=.#=ztgazcwc=(Operator #=z2ralAEU=)
   at #=zk_baTkeGsSyYK2fUlwbWQarGwinOOEZFWx_RVxPj7D6O9uRtCo$N$Ns=.#=zS2xNKVY=()
   at #=zRilPfW9yjsyyd9M4PS5ryiVoXpi92BP5J5B7_acnRuE6_Xx4OxfLIUcO7UHn.#=zKZ4RJV3P5x$f(BaseOperatorCollection #=zZHouqJo=, Resources #=zWomeL1c=, Page #=zxTFo4z0=)
   at #=zRilPfW9yjsyyd9M4PS5ryiVoXpi92BP5J5B7_acnRuE6_Xx4OxfLIUcO7UHn.#=zKZ4RJV3P5x$f(BaseOperatorCollection #=zZHouqJo=, Resources #=zWomeL1c=)
   at #=zRilPfW9yjsyyd9M4PS5ryiVoXpi92BP5J5B7_acnRuE6_Xx4OxfLIUcO7UHn.#=z3pizJS0=()
   at #=zRilPfW9yjsyyd9M4PS5ryiVoXpi92BP5J5B7_acnRuE6_Xx4OxfLIUcO7UHn..ctor(Page #=zxTFo4z0=, TextSearchOptions #=zwowWeigxgB2A, Boolean #=zcibWW6qsFiJI)
   at Aspose.Pdf.Text.TextFragmentAbsorber.Visit(Document pdf)
   at ☼↓♥.☻(Regex ☻, String ♥, ☼☼♥ ♣)
   at ☼↓♥.ReplaceText(Regex ☻, ReplacementOptions ♥)
Failed
♫♣♣ Failed for Image 1: Failed to edit the embedded image: System.NotImplementedException: Not supported image type
   at Aspose.Pdf.XImage.Save(Stream stream, ImageFormat format, Int32 resolution)
   at ☻→♥.♣↨♥☼▬↨☻()
   at ☻→♥.♣↨♥☼▬↨☻()
   at ☻↨♥.EditArea(Point ☻, RegionReplacementOptions ♥)

We have tried including the Aspose PDF package. Using version 22.7, redactions are applied successfully, but the resulting file cannot be opened with Adobe Reader. Using 22.6 the same stack traces show up again. Using 22.5 has the same behavior as 22.7.

Sent you the project via email.

Please advise!

@omarinoiu

I haven’t received any email yet. Could you please share the project again at atir.tahir@aspose.com.

Re-sent it. I guess it was the wrong email.

@omarinoiu

I still don’t get the email. If there’s any issue with email sending. Please compress the project to a ZIP file and upload here or to some cloud storage (and share the link).

Please find the project ConholdateLicense4 - Copy.zip (97.7 KB).

1 Like

@omarinoiu

Thanks for sharing the details. We are now further investigating this issue. Your investigation ticket ID is REDACTIONNET-411.

@omarinoiu

This issue is expected to be fixed in API version 22.8. Meanwhile, as a workaround, you can target your application to .NET 4.5 and lower as well as .NET Standard 2.0.
As there’s any further progress update, we’ll notify you.