Free Support Forum

Problems on product licensing

We had an Aspose total license expiring at 25/10/2020 , and we bought the upgrade to Conholdate.
From yesterday a customer (who has an installation compiled at may 2020, with the old file aspose.total.lic) see on all the images a square with the evaluation only notice of Aspose.Imaging
I have some questions:

  1. We were sure that the subscription is required for downloading new versions of the product, but also that the installed products would continue to operate, without the need at every license expiration to renew the installation with a new build. It is not true?
  2. We tried to recompile our software with the new Conholdate license but we receive an error “Invalid license signature” (we tried with the .lic received by email and with teh .lic downloaded from the conholdate website)
    Please suppurt us as soon as possible, thanks in advice

In the meantime I have found that the problem of invalid signature was only on Aspose.Barcode and was a bug corrected on the build 20.10…

@StefanoR

Sorry to know that you’re having the trouble with Conholdate.Total license. Are you seeing this issue with only Aspose.Imaging or with any other API as well? Under which user email your license was purchased? Kindly reply to these two questions so I can escalate this issue for an urgent fix.

You’re right. You do not need to upgrade if you do not want to. But it’s recommended to upgrade to latest versions for better performance, bug fixes, feature improvements, or if you want to use new features.

For example, in this case, if there is a bug in the API which caused this issue then to be able to fix the issue upgrading to the latest version, or at least to the version having a fix is required. I hope this clarifies the situation.

The license was purchased as roberto.dimodica@aemprocessing.com.
We were using Aspose.Imaging 19.12 , the problem seems to be only on this module (e.g Aspose.Cells or Aspose.Email seems ok).
Now we have recompiled all with Aspose 20.10 and the new license Conholdate and all works fine.
Before we tried to use the old Aspose.total.lic with new version (20.10) and it worked also.
So we must however distribute to customers an upgrade (the lic is compiled as embedded resource), but my fear was we need to do so every year…

@StefanoR

This license issue was of rare type. Usually, we do not see such license issues. So hopefully this will not happen again and you’ll not have to redistribute because of this thing. I hope that helps.